Students getting "something went wrong" when accepting assignments

We have been using Github Classroom since November 2020. This worked fine, until recently, students have been complaining that they are not able to accept assignments. When following the link they get the following error:

You accepted the assignment, assignment10 but something went wrong. We have not received any updates for this assignment. You may want to reaccept the assignment.

We were able to reproduce this issue when trying to accept the assignment ourselves.

On closer inspection, the repository assignment10-teamA does get created, however, the students do not get access to it, and the teams do not show up as having accepted in the assignment. When re-accepting the assignment, they get the same error, and further repositories assignment10-teamA-1, assignment10-teamA-2, etc. get created, none of which can be accessed by the student.

This also happens for older assignments that used to work fine. Also, the issue seems of a temporary nature: It was first reported on 22. Jan 2021, 09:48 am and disappeared again 12 hours later. Now it is back.

Has anyone experienced a similar issue, or does anyone know what may cause it and how to resolve it?



Could you provide a link to the classroom repo please?

I’m seeing the same issue. I’ve been using Github Classroom for two years now, and this is the first time I’ve seen this issue.
The (private) assignment repo in question is here:

And my org is wustlcse204.

I created a new Github test account and was able to reproduce the issue as follows:
When accepting the assignment, users see a message like this:

There was an error accepting the assignment, please try again. If this problem persists, please contact support.
You’re ready to go!
You accepted the assignment, 01 Hello World.

Your assignment repository has been created:

After that, there is a prompt for login credentials with the message “Your old project requires credentials for read-only access. We will only temporarily store them for importing.”


I’m having similar issues. It seems the private repos are not working correctly. When I go to create a new assignment the GithubClassroom doesn’t have access to the private repos of my classroom organization.


1 Like

Orga we are using:

If you need another link, let me know, am not sure what you mean by “classroom repo”.


I’m seeing a similar issue even with public repos - everything was working fine up until this afternoon. Now my students can’t accept any assignments and are seeing “There was an error accepting the assignment. GitHub repository could not be created from template, please try again.” This occurs for even a brand new template.

1 Like

Yes - this is the same problem we were having here: No access to template repo when creating Classroom

You will need to fork or transfer the template repository to the destination organization if you want to keep the template private, check that the new version of the template is still set to be a template, and then update the template repo source in GitHub Classroom for the assignment.

I ended up making all the repo templates public to get this working quickly. However, whatever was changed yesterday that made it stop working with private templates corrupted all my classrooms - changing the repos to public did not allow students to access and accept the assignment. I tried creating new assignments in the classrooms using the public templates and students still could not accept them. I had to create entirely new classrooms with the repos.

I wonder why making the templates public would break the classrooms.

I think forking the template repo to your classroom organization might be the easiest way. I initially forgot to upgrade my org to the Team plan and so I could not fork a private repo. So my quick solution was to just create a repo based on the template in my classroom organization, make this a template again and set it as the starter repo. Students reported that there weren’t any errors anymore and everything worked. It’s just a quick hack though.

Did we get any resolution for this? It started happening with us also github reaccept error · Discussion #42 · rtCamp/learn · GitHub

Hi @rahul286!

This was a recent bug introduced into Classroom and we just released a fixed for this. If you are still experiencing issues, please reach out to us at support .


Thanks for looking into this quickly. :pray:

I will check again and if the issue persists, will share more details here.

Thank you FYI, I will concern it as well.

I can confirm that it’s fixed and working well. Thanks :pray:

I am getting this issue with student assignments today. I have verified that the repos are public and are template (and they worked previously). I also created an entirely new classroom and this is occurring with a brand new classroom and brand new assignment. Please see the below image:

We suddenly started getting this today too. Sign in to GitHub · GitHub

Several of my students already accepted the assignment before today without issue, but today people started having problems and now no one else can get in. The assignment is due in less than a week. Not great timing!

@stephaniegiang I’ve opened up a support ticket with the link you had above. Is there anything else that we should do?

1 Like

I also am getting reports of this issue this morning (July 27). We are on a condensed summer term, so a fast solution is requested.

1 Like

It seems like it just started working again for my students.

It appears to be working again for my students as well.

The student who reported it said that they rebooted and it worked. (
Which may have been lucky timing or might be a thing to try if you still have stuck students.)

© 2017 GitHub, Inc.
with by
GitHub Education