Stuck loading... in VSCode

It’s a sporadic issue, but I’ve had several students where they’ll click on the Open in VSC link, VSC opens like it should, but it never opens the files. The GitHub tab just shows Loading… instead of the list of assignments.

Restarting usually fixes it, but not always. Anybody have something else to try?

Are you using the add IDE option in a classroom assignment? (i.e. the button link looks something like https://classroom.github.com/online_ide?assignment_repo_id=XXX...)

Have you tried the direct vscode link?: vscode://github.remotehub/open?url=https://github.com/organization/repo (replace organization with your classroom org and repo with the student’s assignment repo).

(The Open in VSCode button doesn’t work for me either.)

Yes, we’re using the button. What’s weird is it works for 95% of the students, nd it’s not always the same students. It may work perfectly for Sue today and not tomorrow.

I’ll try that other link. Didn’t know that was a thing. I tried yesterday with open.vscode.dev after reading another post with a similar problem and turned out that domain was blocked on our network for students. Hopefully that’ll get unblocked today.

© 2017 GitHub, Inc.
with by
GitHub Education