Self-hosted Actions runner only seeing jobs from last semester's classroom

Last semester a student test case with an infinite loop used up all of our Classroom-wide Actions minutes, so I set up a self-hosted runner using Docker and ephemeral runners based off of this example. It worked very well last fall for multiple assignments and ~50 student repos per assignment.

However, after setting up a new classroom (in the same organization) this semester, repos in the new classroom cannot run workflows in the self-hosted runner. Any actions workflow just sits forever at Waiting for a runner to pick up this job.... Workflows added or updated in repos from last semester continue to work fine, though.

Is there something that needs to be done to get the runner to see workflows from the new classroom?

The runner log in case there is something helpful in there: https://moyix.net/~moyix/Runner_20220130-064756-utc.log

Aha – this was in fact a mistake on my part. Self-hosted runners don’t run workflows from public repositories by default – and I had accidentally made the student homework repositories for this semester’s assignment public. Making them private fixed it :slight_smile:

2 Likes