New repositories are not created correctly

Hi there,

I am trying to run a course with GitHub classroom. I set up a private repository and send and assignment for enrollment to my students. One repository was created correctly, but most of the repositories are empty. Any idea what went wrong? Students sais they had a message “That may take a while” and waited for 90min.

kind regards
Soren

Hey! Would you mind sending us a message at https://support.github.com/ with more information about the assignment that’s failing? It’ll be easier for us to help get this sorted over there :slight_smile:

1 Like

Will do that right away.
Cheers

I used to have that problem a while back but shifted over to using template repositories last fall and it hasn’t happened again since. If you aren’t already doing that, you can give it a try and see if it gets you over the hump.

We have had similar problems to the one you describe before and usually - if you have been using GitHub Classroom for long - y the reason is this: the GitHub Classroom developers have updated the app. The solution is to tell the students to revoke the authorization to GH Classroom and then grant it again for the new version. Has always worked for me and my colleagues.

This issue has just started appearing for me in the last two days. All assignments worked correctly this semester so far, but for the one I created two days ago, 4 repositories have already been created incorrectly, meaning that they are empty.

I have been using template repositories, and I don’t think it’s about re-authorizing since students have only been using it for a little over a month now.

As a quick workaround: can I delete these repositories, and can the students accept the assignment again (and maybe then the repos will work), or is there any other suggested way to proceed?

Wolfgang

On my end, I’m pretty sure that this has happened because I edited the assigment after some students had already accepted it. To be precise, I changed the repository prefix because I forgot to initially edit it. All repos before that were created correctly, after that all were broken or couldn’t be created at all.

I have submitted a bug report via https://support.github.com/contact. I hope that helps.

Regards,
Wolfgang

© 2017 GitHub, Inc.
with by
GitHub Education