Missing setuptools in autograding Python workflow

Hi,

I tried to setup autograding in a python assignment strictly following https://github.com/education/autograding-example-python

It worked some days ago but now it complains with the following error. It seems like setuptools is missing when installing iniconfig.

Run education/autograding@v1
Collecting setuptools
Downloading …/setuptools-50.3.0-py3-none-any.whl (785kB)
Collecting pytest
Downloading …/pytest-6.1.1-py3-none-any.whl (272kB)
Collecting py>=1.8.2 (from pytest)
Downloading …/py-1.9.0-py2.py3-none-any.whl (99kB)
Collecting importlib-metadata>=0.12; python_version < “3.8” (from pytest)
Downloading …/importlib_metadata-2.0.0-py2.py3-none-any.whl
Requirement already satisfied: attrs>=17.4.0 in /usr/lib/python3/dist-packages (from pytest)
Collecting iniconfig (from pytest)
Downloading …/iniconfig-1.1.1.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
ModuleNotFoundError: No module named ‘setuptools’

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-u03dqd1z/iniconfig/

We were hit with this yesterday, too. It appears to be related to a new release of iniconfig yesterday, more details are on this issue, here.

I’m relatively new to using GitHub and very new to the autograding. I just set up my first one in Python on Thursday, used my dummy student account to make sure it worked, and then introduced it to my students today - and also found this error. I looked at issue #17, but could not figure out what I needed to do based on that. Is there a way to fix this error?

© 2017 GitHub, Inc.
with by
GitHub Education