LTI Moodle error

I once had Github classroom working with Moodle using LTI . - user names worked and it all was smooth.

Now it stopped working, it is not clear if Moodle was updated or if Classroom changed.

I created a new external tool , with correct key and secret etc and I get an error. I used to get a 404

Now I get this error
‘’’
GitHub Classroom

An error occurred when launching the external tool: The launch credentials could not be authorized. Ensure you’ve entered the correct “consumer key” and “shared secret” when configuring GitHub Classroom within your learning management system.
‘’’

Anyone know how to debug this?

If iI enable the ‘select content’ option on moodle tool i get a error 404
classroom.github.com refused to connect.

Thanks

4 Likes

I have the same problem. Not only for the newly created classroom but all the existing ones all become unreachable and are showing the same error message.

Thanks.

For what it’s worth, I have the exact same error, but with Canvas LMS.

Same problem here. A couple of weeks ago this was working and since last week I also get the error:

“An error occurred when launching the external tool: The launch credentials could not be authorized. Ensure you’ve entered the correct “consumer key” and “shared secret” when configuring GitHub Classroom within your learning management system.”

i’ve doubled-checked the credentials they’re fine, i’ve removed and created again the GH Organization and the GH Classroom and none of these reset-kind-of-action fixed the problem.

thanks,

robert.

Just to let know you that today I tried again to connect Moodle with GH Classroom, without changing a single setting, and it works again. No idea how this has been fixed.

greetings everyone,

robert.

© 2017 GitHub, Inc.
with by
GitHub Education