Error Creating New Assignments

Has anyone run into the “Invalid repository selection, please check it again.” error when creating a new assignment on the first step, “Assignment Basics”? What’s odd is that I haven’t even selected a repository by that step…

I think am getting the same error when I try to create a new assignment. I also can’t even get to the page to select a repo so I have no idea how to fix it. Does your error look like this?

If it’s the same bug I encountered earlier you can hit the cancel button and start creating it again from scratch.

For the devs: I think the reason it happened for me is because the form saves progress and will save an empty/invalid repo name on the second step. If you close and reopen the form you will start on step1 but with an invalid repo name still saved that fails validation. Step2 inputs shouldn’t be validated at step1

I am also getting the same error. Have you found the solution?

I haven’t found a solution unfortunately. I have to admit I haven’t tried very hard to at this point though. @mattosborn’s suggestion to start over is usually the direction I have to go in order to clear things up.

“Have you tried turning in on and off again?” +1 on @mattosborn post.
I got this issue too and for me logging out and then in again solved it.

It seems it saves the “empty” repo selection on the next step if you for some reason cancelled creation.
Wich locks you from submitting the first step sience there is a problem in the next step.

Reloading page dit not help. But as i said, log out, log in!

All the time. This is annoying as no clue is suggested what the root cause might be

© 2017 GitHub, Inc.
with by
GitHub Education