Endless (re)authorization loop? (known issue)


(Joel Sommers) #1

Hi folks,

I have an assignment set up through classroom, and while some students have been able to successfully accept the assignment invitation link, a couple of students have had authorization problems. One problem in particular has been that a student gets stuck in an endless authorization loop in which he gets to a screen that says “reauthorization required”, clicks on the “authorize” link, then winds back up there. At the top of the screen it says “this application has had an unusually high number of requests to access your account”.

Any ideas on what’s happening here? (For github folks watching, I can give you the github handle for that particular student if it helps.)

Thanks -
Joel


(Joel Sommers) #2

Figured this out. But I’m still seeking some explanation.

The problem was that the student had previously taken a course that used github classroom. I had him leave that organization as well as revoke oauth for classroom. He was then able to accept the assignment. On the auth screen he’d gotten stuck on, it looked like github was trying to authorize him for the organization associated with his previous course, not the current one. So one followup question: is it not possible to be in two separate courses that use github classroom simultaneously? The auth problem my student experienced would suggest that it isn’t possible.


(Vanessa) #3

@jsommers sorry your student encountered this issue.

Students should be able to access more than one Classroom at a time.

If you private message me the student’s account, we can dig in further.

cc @tarebyte.


(Joel Sommers) #4

@mozzadrella not a big deal, just glad it’s sorted. thanks for clarifying about multiple classrooms — I’ll send the account separately to follow up.


(Geoff Schmit) #5

@jsommers I saw this issue yesterday for the first time. Students that were in my GitHub Classroom last year ended up in the same endless authorization loop. I didn’t pick up on the pattern until I read your post. We worked around this issue by having students log into github.com and then log in directly to classroom.github.com. At this point they were able to complete the authorization. They then would click on the link to accept the assignment, and it would work.

@mozzadrella Is this issue captured? Do I need to file an issue or provide more details?


(Vanessa) #6

@gcschmit if you would file an issue I would be much obliged :sparkles:


(Geoff Schmit) #7

https://github.com/education/classroom/issues/1144


(Lindsay Ward) #8

I had a student complain of this problem too.
I suggested they try a different browser, and it worked for them in Firefox (instead of Chrome).


(Mike Borowczak) #9

I’ve had this problem as well - students using different browsers, trying private windows, clearing all caches.

Ultimately here’s is the work-around that has worked for my students:

  1. Sign into github
  2. Sign into classroom.github.com (directly)
  3. Use the assignment link

After they’re associated with a classroom future use of assignment links works as expected.