Download all assignments 💾 with Classroom Assistant

You’ve asked for a way to download all of your course assignments at once.

Now you can save time and download all assignments with the click of a button with GitHub Classroom Assistant. Try the tool that students have used to create 3 million coding assignments over the past three years. :tada:


Great share @mozzadrella,
Could it be that the download link isn’t showing on the site itself?
After signing in I can see the option to download all repos in GitHub Classrooms (requires the desktop app it states) however on the Classroom assistant itself I’m not seeing any option to download the assistant.

Anyone that has managed to download the assistant? Feel free to share the location :wink:

I’m glad it’s not just me that’s missing a download link or button!

Edit: after browsing the source code of the page :slight_smile:
Sorry for peaking:

Link for Windows:
Link for Linux:
Link for Mac:

But someone will need to fix the visibility of these on the page itself :wink:


Thanks, @ConsoleFriend! I came here looking for help because I similarly couldn’t find the link.

Followup: I just installed the Linux version under Ubuntu, and I can’t get it to work. I get an initial startup screen, with a button labeled “Log In With Classroom”. I do so, then see a GitHub authentication screen, within which I enter my username and password; and then the whole app freezes.

All of my assignments come back with ‘Could not find assignment.’ when I copy and past the assignment url into the form.

1 Like

Yes, same with me.

It’s sad to see that it’s still buggy.
This could be a really useful tool.

I’m not experiencing any of the issues above. What version are you using?

Well, I tried again just now and it looks like it’s working.

I’m on version 1.0.1 but version number did not change since yesterday, so I guess that’s not the issue.

Maybe something else was causing these issues. I’ve been locked out of Classrooms this afternoon. But now it’s working again.
I did see some weird session variables being used in reference to … which I wasn’t really expecting to be in my local storage for GitHub Classrooms. :smile:

That is great. For my department where nearly 100 students sitting in the same info room, a unified git_tool should be a great help for installing, co-operating et etc…Thanks for the team.

Both my colleague and I are getting errors when we try to push the students code back up to git. My colleague uses comments in the code to grade and give feedback, so he has to be able to push up. When pushing we both get a similar error. Everything looks fine from a git perspective but it wont connect. I was able to push when I cloned using a bash script… so the issue is in the assistant, not the repository.

Here is one of my errors.

C:\tmp\Lab 0-10-13-2018-06-41-26\abdulwaha (master)
λgit push
remote: Repository not found.
fatal: repository ‘’ not found

I tried Classroom Assistant for the first time tonight hoping it would simplify things. I’m glad I tried to push (and got a similar error as @phannan) before I used these for my round of grading. It would have been frustrating to make the changes and commit them, but not be able to push. I’m going to open an Issue in the repository about this. Nope, there’s already a relevant issue, to which I just added my comment:

It’s great news, but unfortunately I could not install it because of an error that I can not fix.

I’m working on Ubuntu 19.04


Hi @DannasCornell ! Thank you for the information. I would recommend writing an issue in the Classroom Assistant Repository so that we can address it: