Classroom starter code broken today?

I tweaked a test case on an existing assignment today and github decided to drop the repo I’d been using as my starter code from the assignment, leading to some students who are only starting the assignment today to get empty repos. When I tried to re-add my starter code, calpolycpe/lab-06, the github autocomplete bar (that only sometimes shows up) only showed me student lab repos that students had already started. I tried making my starter repo public, no dice. Finally, I searched for the template I used for the previous lab, updated the assignment to use that (although it didn’t show in the search either), then went back in and was able to point it to my calpolycpe/lab-06. I really hope I didn’t mess up the repos of students who’d already done the work. What I want to know is how on earth did this happen and what steps if any can I take to prevent this from happening again?

:wave: @adanowitz,

Would you mind reaching out to us at support.github.com with some more information? It’d be handy to know the URL of the starter code repo, and the organization you’re using for your Classroom. You can just copy/paste the message you wrote here, it’ll get routed to our team!

Support fixed the bug for individual assignments, but now I’m unable to add a starter repository for a group assignment. It allows me to search for it and select it, and when I click update assignment, it doesn’t give me an error message, but it also jettisons the starter repository and gives my students empty repos.

© 2017 GitHub, Inc.
with by
GitHub Education