Assignments overview says "No tests have been run"

I saw people (@caio96 and @beopst) having the same problem in the context of this thread, but the thread itself is about a different problem and has a solution already.

My problem is that the assignments overview always says “No tests have been run” - though they have!

I created a template repository with a Java project and an assignment from this template. I added test cases running I/O comparison tests and/or JUnit tests. When I complete the assignment, the tests run just fine . I also tried passing/failing them and I even created a dummy GitHub account to do this assignment “from a student perspective”. But still:

Screenshot from 2020-08-26 11-24-01

Can anyone help with this?
Thank you in advance!

3 Likes

I am having the same problem.

same. anybody find a workaround?

I opened a support ticket @ GitHub about this. I will report back when I get a reply.

Just to let everybody know: I got a very friendly reply to my support ticket. It seems we actually ran “into an existing bug” that they’re already looking into. I think it’s okay to quote this here, right? (If it isn’t please let me know)

There seems to be some issue with Classroom being updated after the autograding tests have been run. We have an issue for the Engineering team to look into this and I will update y’all when we’ve made progress. I have access to the community forum so I will just update your thread when we have that info so everyone else can see as well!

So we’ll have to wait for that. But at least it seems to be an active issue, so I have a good feeling. Thank you all for +1ing this so it didn’t look like I am just a single dumb user who didn’t understand how to use the product :hugs:

3 Likes

While we wait for a fix, I wrote a quick tool to download the “grades” from a unit test suite:
https://github.com/aronwc/ghc-utils

This assumes the tests have all been run via the GHC workflow and returns an output like “Points 10/20”. It grabs the output for the latest commit and write a csv file with the results for each student.

3 Likes

Any update regarding to this issue?

Not an official one, no. Does that mean you are running into this issue today? I didn’t try it for a while. That’s good to know.

Classrooms asked for additional permissions lately, so I thought they’re working on something. Well… looks like we’ll have to wait.

For me it’s quite clear I won’t be using Classrooms for the coming semester. It just lacks the functionality I’d need. Atop the problem mentioned in this thread, I’d need a possibility to set up individual deadlines for students. Support ticket pending :wink:

I found the solution regarding this issue here

Tell the students to go and “update” (see near the bottom of the thread for fuller details), which may fix the issue for them.

Hi @intechristina,

I don’t see how this is a solution to the problem discussed here. Isn’t this other thread about Repl.it?
Also, maybe you meant to link to this post in the thread instead?

I will test if this makes autograding work… but I have to say this surely isn’t a “solution”. It should just work, right? :grimacing:

There seems to be a block on fully configuring the accepted assignments. The “solution” in the other thread effectively triggers the set of commits required to finish configuring things. That’s why it may help here (in addition to fixing the missing Repl.It button).

And I’d agree…it’s more of a stop-gap measure than an actual solution.

I guess, “reaccepting” the assignment is the only “workaround” at the moment. It is not a solution since the problem is still there, and GHC simply should work as expected.
Thanks, everyone!

© 2017 GitHub, Inc.
with by
GitHub Education